images/paint.svg Materials Editor Panel

Materials contain the specification for color, reflectivity, transparency, textures, and bump-maps of a surface finish. All materials have basic settings. The default material is white and matte, with no reflectivity or transparency. For the best results use Flamingo specific materials.

Materials can be assigned to layers, objects, and blocks. Assignments can be made by dragging and dropping on to objects or various controls. See Material Assignments for more information.

Once assigned, materials are stored in the model. The material, textures, and all support files for rendering can be stored within the Rhino model with properly set Rendering Options.

Materials, environments, and textures are stored in the model, but rendering content can also be saved to files that can be shared between models. Content can be dragged between Rhino sessions and into a folder. Color swatches can be dragged and dropped in the same way. The Libraries Panel displays the default content folder. Use this to drag and drop content into the model or to drag and drop model content to an external file.

images/material_editor_panel.svg

Where can I find this command?

There are several options to find the Materials tab.

The Material Editor Panel is split into discrete sections. Based on the material type, the advanced panels may vary.

You can drag colors and textures from the color swatch and drop onto any other color swatch or control in the Material Editor, Texture Palette, or Environment Editor.

Materials Panel
  1. Settings Bar
  2. Material List
  3. Window Divider
  4. Material Properties Section
  5. Name
  6. Material Properties Panels

Settings Bar images/callout_1.svg

Use this bar to navigate the material during its development.

images/met_leftarrow.png Back Arrow

Walks back though the current material or the previously selected materials. For instance, materials with textures have multiple layers. Use this arrow to return to the parent material from the texture details.

images/met_rightarrow.png Forward Arrow

Walks forward though the current material or the previously selected materials. For instance materials with textures have multiple layers. Use this arrow to return to the recently used texture from the parent material.

images/material_editor.png images/texture-2dchecker.png Currently selected material name

Displays the current material name and level. For instance, if there is a texture or a material procedural level the “>” will show. A good place to see where the editor is in a material.

images/library_default.png Tools menu

Displays the Tools menu. This is an extensive menu of commands, settings and utilities related to materials.

Materials List images/callout_2.svg

This lists all the materials contained in the model. From this list:

images/add_material.png Add new material

Scroll down to the bottom of the Material list to see the add icon.

Opens the Render Content library of materials. The materials in the library act as templates for creating materials in the model.

Material Context Menu

This menu is available by right-clicking on a material listing. See the Tools Menu for details on the many options in this menu.

New Material Context Menu

This menu is available by right-clicking on a blank area of the Material List.

images/toolbarlus.png Create New Material

Creates a new basic matte white material.

images/paste.png Paste

Creates a new material based on the Clipboard contents.

images/pasteasinstance.png Paste as Instance

Creates a new material based on the Clipboard contents that is linked to the original through instancing.

images/grid.png Grid

Displays the previews as a grid of thumbnails.

images/list.png List

Displays the previews as a list of thumbnails.

images/tree.png Tree

Displays the previews as a tree showing nesting.

images/horizontal.png Horizontal Layout

Displays the previews to the left of the controls.

images/showpreview.png Show Preview Pane

Displays the preview properties for the currently-selected thumbnail. Set the preview geometry, size, background, rotation behavior.

images/floatthumbnail.png Float

Floats the preview image in a resizable window.

Thumbnails

images/small.png Small

Sets the thumbnail size to the smallest size.

images/medium.png Medium

Sets the thumbnail size to medium size.

images/large.png Large

Sets the thumbnail size to large size.

images/showlabels.png Show Labels

Displays thumbnail name labels when in Grid mode. List mode always displays labels.

images/showunits.png Show Units

Displays size in model units.

images/autoupdatethumbnail.png Auto-Update Preview

Automatically updates all previews as settings change.

images/updateallpreviews.png Update All Previews

Update previews manually when Auto-Update Preview is off.

Window Divider images/callout_3.svg

Drag on this divider to change the length of the Material List. If you lengthen the Material List, the Material Properties Section shortens.

Material Properties Section images/callout_4.svg

Material Name images/callout_5.svg

This is the name of the material. The material name is also saved as the file name when exporting the material to the library. Note: Materials are stored in the Rhino model. Unique materials can have the same name in different Rhino models.

Material Panels images/callout_6.svg

The Materials Properties section is filled with several direct Material panels. Clicking on the grey title bar will roll up the material panel, hiding the contents of that panel. Click on the title bar again to show contents.

Material Panels will vary based on the type of material and the current active material level. For more information on specific material panels see Flamingo Materials.

Tools menu images/library_default.png

These settings also appear on right-click context menus for the thumbnail previews and the thumbnail backgrounds.

images/assigntoobjects.png Assign to Selection

Assigns the current material to selected objects.

To assign a material to objects
  1. Click Assign to Selection.
  2. In the Rhino viewport, select the target objects.
To preselect objects
  1. In the Rhino viewport, select the target objects.
  2. Click Assign to Selection. The target objects can be selected either before or after clicking Assign to Selection.
To drag and drop materials to objects

images/assigntolayers.png Assign to Layers

Assigns the current material to layers.

To assign a material to layers
  1. Click Assign to Layers.
  2. In the Choose Layers dialog box, check the boxes for the material assignment.
To assign materials from the Layers panel
  1. In the Layer panel, select one or more layers and click the Material column.
  2. In the Layer Material dialog box, select the material to assign.
To drag and drop a material to a layer

images/materials_selectobjects.png Select Objects

Select objects in the model for material assignment.

images/toolbarplus.png Create New Material

Opens the Render Content library of materials. The materials in the library act as templates for creating materials in the model.

images/import.png Import Material from File

Imports materials from a saved Rhino .rmtl file.

images/savetofile.png Save to File

Saves a material to a Rhino .rmtl file.

images/changetype.png Change Type

Changes the material to a different type.

images/changetype.png Change Type (Copy Similar Settings)

Changes the material to a different type. The default behavior depends on the current state of the Rendering Options > Copy similar settings when content type is changed box. If checked, compatible settings from the old content will be copied to the new one.

images/reset.png Reset to Defaults

Changes all the material settings to the default white, matte, non-reflective, untextured material.

images/copy.png Copy

Copies the selected material to the Windows Clipboard. The Clipboard can then be pasted into the editor to create a new material or pasted directly into a folder to create a library file.

images/paste.png Paste

Creates a new material based on the Clipboard contents.

images/pasteasinstance.png Paste as Instance

Creates a new material based on the Clipboard contents that is linked to the original through instancing.

images/delete.png Delete

Deletes the selected material.

images/rename.png Rename…

Renames the selected material.

images/duplicate.png Duplicate

Copies the selected material to a new material with the same settings.

images/removeinstancing.png Remove Instancing

Removes the connection between instanced materials.

images/floatingpreview.png Floating Preview

Floats the preview image in a resizable window.

images/grid.png Grid

Displays the previews as a grid of thumbnails. The editors default to Grid mode.

images/list.png List

Displays the previews as a list of thumbnails.

images/tree.png Tree

Displays the previews as a tree showing nesting.

images/small.png Small

Sets the thumbnail size to the smallest size.

images/medium.png Medium

Sets the thumbnail size to medium size.

images/large.png Large

Sets the thumbnail size to large size.

images/horizontal.png Horizontal Layout

Displays the previews to the left of the controls.

images/showlabels.png Show Labels

Displays thumbnail name labels when in Grid mode. images/thumbnaillabel-001.png List mode always displays labels.

images/showunits.png Show Units

Displays size in model units. images/thumbnaillabel-002.png

images/rename.png Show Preview Pane

Displays the preview properties for the currently-selected thumbnail. Set the preview geometry, size, background, rotation behavior.

images/contentfilter.png Content Filter

Opens the Content Filters dialog box.

images/rename.png Properties

Opens the Preview Properties dialog box.